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Troubleshooting Guide 
This section provides guidance to resolve popup errors or display issues, and to understand warning 
boxes that may be encountered in CTB Quote™ Plus.  Administrator permissions may be required to 
resolve account settings.  Sections with more details are referenced, as applicable. 
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Login Issues 

Location Popups 

Location management is an administrator action within Account Information.  Administrators must 
assign each Representative with access to at least one Location.  

Scenario: Login is successful followed by a ‘Log Off’ popup (screenshot below) 

 

Resolution:   

• An administrator must log in to CTB Quote™ Plus to resolve.  //If you are the administrator and 
receive a Location error, contact your Milgard Sales Representative for setup resolution.// 

• Navigate to: Account Information>My Company Profile 
• Select the Manage Location button  
• Select the Representative from the drop-down list in order to assign a Location 
• Select Allow Access to at least one Location.  Set a Default if applicable. 
• Manage Locations has an OK button to save changes.  Select OK to save the Location update.  

 

If the Manage Locations screen is closed, without clicking OK, the changes are not saved!!!  
See Account Information – Administrator section for more details. 

 

! 
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Invalid Login 

A valid User ID and Password are required to log in to CTB Quote™ Plus.  Passwords are case sensitive.   

Scenario:  an unsuccessful log on message appears on the login screen (screenshot below) 

 

Resolution:   
• Check that the Caps Lock key (on the keyboard) is not locked on (unless the password is in all 

uppercase).   
• Use the Forgot Password link if you have forgotten your password. // A valid User ID and Email 

address on the My Profile page is required to successfully receive a new password via Email.// 
• Verify the User ID with your Administrator. User IDs are not case sensitive. 
• Have the Administrator log in to CTB Quote™ Plus and change your password: 

o Account Information>My Company Profile > Representatives tab 
o Select the Representative and provide a temporary password for the Representative 

//Representatives can change their own password in Account Information>My Profile once 
they can successfully log on to CTB Quote™ Plus with a temporary password.// 

IE Login Screen 

Scenario:  Internet Explorer users may see field misalignment (misaligned fields are displayed below).  
Compatibility Mode must be turned off to resolve. //See Internet Explorer Issue for more details.// 

 

Resolution:   
• In the IE browser, uncheck any compatibility checkboxes in Tools> Compatibility View Settings
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Display issues   

Internet Explorer (IE) Issue 

Scenario:  My Company only allows Internet Explorer and CTB Quote™ Plus doesn’t display correctly. 

Resolution:   
• Compatibility Mode must be turned off (disabled) in Internet Explorer. 
• In IE menu> Tools> Compatibility View Settings, uncheck compatibility checkboxes. 
• Remove CTBQuotePlus.com if listed as a Website in Compatibility View.  

 

Search Icon is Hidden  

Scenario: Within the Item Configurator, some fields do not display the Search icon for visual selection. 

Resolution: 
• Screen resolutions of 1920 or less can limit the visibility of screen data.  A horizontal scrollbar 

will appear at the bottom of the Item Configurator to scroll left and right for hidden areas.   
• Scroll to the right to view the Search icon for fields that are not fully visible.  
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Unexpected Application Behavior 

Scenario 1:  Page has missing sections, buttons, or fields 

Scenario 2:  Inactive or no visible button response  

Scenario 3:  Unexpected behavior or incorrect link to a new page 

Scenario 4:  CTB Quote™ Plus display an Error screen on the Login page after some action 

 

The above scenarios may occur when CTB Quote™ Plus has had application updates but your browser is 
‘caching’ information.   Browsers will cache web pages in order to load them more rapidly for future 
visits.  Caching can interfere with updated information available from web applications.   

Resolution:   
• Log Off and close the browser, prior to logging back in, to resolve most web application cache 

issues. 
• Manually clear the browser cache to resolve unexpected application behaviors. 

o Press Ctrl + Shift + Delete keys  simultaneously to clear the cache in most browsers. 
o Close and reopen the browser prior to logging into applications. //If Ctrl + Shift + Delete 

does not work for you, clear the cache using the browser  Menu option (below).// 
• Browser Menu Resolution  

o Google Chrome:  
 Menu option:  Open the settings Menu>History> Clear Browsing data 
 Ensure Images & Files and Hosted app data are checked to be cleared 
 For timeframe, select “the beginning of time”  
 Close and reopen the browser prior to logging into CTB Quote™ Plus  

o Firefox:  
 Menu option:  Open the settings Menu>Privacy…History section> Clear your 

Recent History link 
 Ensure ‘Cache’ is checked to be cleared, then click Clear Now 
 For time range, select “Everything” 
 Close and reopen the browser prior to logging into CTB Quote™ Plus  

o IE 9+: 
 Tools> Delete Browsing History 
 Ensure Temporary Internet Files is checked to be cleared, then click Delete 
 Close and reopen the browser prior to logging into CTB Quote™ Plus   
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No Info Link Data 

Browser settings may affect the way that PDF’s are opened.  Most browsers display PDF links inside a 
web page which CTB Quote™ Plus will display within the Information panel when an Info Link to a PDF 
is selected.   

Scenario: No information is displayed in the Information panel in the Item Configurator when an Info 
Link is selected. 

Resolution: 
• The PDF may have downloaded instead of opening in a tab or window.  Check the Downloads 

folder to see if the PDF downloaded. 
• Change the browser settings to open PDF’s within the browser instead of saving (or 

downloading) by default 
o Firefox (screenshot below) 

 Settings Menu>Options>Applications 
 Find Adobe Acrobat Forms Document under Content Type column 
 Ensure that the Action column reads Use Adobe Acrobat (in Firefox).  Use the 

drop-down menu to change the Action for Adobe Acrobat Forms 

 

o Google Chrome 
 Google displays PDF’s within the browser by default 
 Open the Settings Menu> Settings > Show advanced settings> Privacy > Content 

Settings> Plugins > Manage Individual Plugins Manage Individual Plugins to 
change how PDF’s are opened. 

o Internet Explorer (screenshot below) 
 IE displays PDF’s within the browser by default 
 Open Tools> Manage Add-ons  
 Ensure that Adobe Systems, Incorporated (Adobe PDF Reader) is enabled. 
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Place Order Data Missing 

All fields on the Header tab are meant to reference the Customer.  The Place Order Screen fields are for 
reference from the Dealer to Milgard.  This behavior is consistent:   a Customer-requested ship date is 
available on the Header tab and a Dealer-requested ship date, on the Place Order screen. Both dates 
can be different with the Dealer Requested Ship date earlier than the Customer-requested date.  
Milgard only sees the Place Order fields.   

Scenario: I entered a PO Number and Requested Ship date on the Header tab and CTB Quote™ Plus is 
asking for the same information on the Place Order screen. 

 

Resolution: 
• The Milgard required fields appear on the Place Order screen (Dealer to Milgard). 
• Customer Header tab fields are available for Customer referencing, if applicable.  If the PO 

Number should appear on Print Bid Documents for the Customer, use the same PO Number for 
both screens. 

Change Log is Empty 

The Change Log functions as an audit trail for primary Quote modifications.  Versioning and Copy 
functions both start with a new audit trail or Change Log so that modifications that occur on that 
Version or Copy are recorded as from the moment created.  

Scenario 1: I made a new version of my Quote and my Change Log does not reflect all of my entries. 

Scenario 2: I made a Copy of my Quote and the Change Log does not reflect any entries. 

Scenario 2: My Library configured Items, added to the Shopping Cart, are not in the Change Log. 

Resolution: 
• There is no error with an empty Change Log for new copies/versions.  By design, the Change Log 

audits the changes made as of creation date.  Items already in the Shopping Cart from a Copy or 
Version cannot be carried over, as they occurred on a different copy/version.   

• For complete audit trail data in the Change Log, only create new Quotes and create the Items to 
be added to the Shopping Cart.  The Change Log does not monitor Library inserts. 
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Usage Issues 

Auto-Save Not Working  

All of the main pages in CTB Quote™ Plus (e.g., Quotes, Customers, Projects ) auto-save data.   

Scenario:  Price Adjustments, Attachments, Change Password, or other button popup screens did not 
save my changes or actions. 

Resolution:   
• Most CTB Quote™ Plus pop-up windows or screens offer the option to view pop-up data.  They 

can be canceled or closed without saving changes.  To save changes when the OK or Save 
buttons are available, be sure to select OK or Save when changes have been made.      

Attention Required or Invalid Lines in Shopping Cart  

Unresolved fields in the Item Configurator require attention.  This can occur from changes to Quote 
Location, a Global Style change, or a product update for Items in the Shopping Cart.      

Scenario 1:  I see “Invalid Lines in Shopping Cart” warning at the top of my Quote. 

Scenario 2:  I used Global Changes and now see ‘Attention Required’ in the Shopping Cart area. 

Scenario 3:  I used the Validate All button and now see ‘Attention Required’ in the Shopping Cart area. 

 

 

Resolution:   
• Click the Edit Item link to open the Item Configurator.  Answer any unresolved fields that are 

prompted.  Select the Continue and Finish buttons to complete the build, in order to resolve.   
The Shopping Cart will update and the ‘Attention Required’ message should disappear.  

• See Quotes> Shopping Cart section for Line Item editing details. 
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Validation Required Warning 

Validation in the Shopping Cart may be required to ensure that the most current application settings 
(e.g., build requirements and pricing checks) have been verified (i.e., validated).  It is a best practice to 
use the Validate All button prior to converting a Quote to an Order (i.e. Place Order function) to 
eliminate errors.  

 

Scenario 1:  I copied a Quote and when the New Quote opened, there is a “Validation Required” in the 
Shopping Cart area. 

Scenario 2:  I added Quote Items from the Library and see “Validation Required” in the Shopping Cart. 

Scenario 2:  I applied Global Changes to a Quote and see “Validation Required” for Items in the 
Shopping Cart. 

Resolution:   
• Click the Validate All button to clear the requirement message from the Shopping Cart.  
• If the ‘Attention Required’ warning appears, see Attention Required Resolution 

Delete Dealer Option Warning 

A Warning pop-up box occurs when trying to delete a Dealer Option.  

Scenario:  When attempting to delete a Dealer Option, the Warning popup box appears. 

 

Resolution:   
• If the Dealer Option has been previously used on a Quote or Order, it cannot be deleted. To  

prevent future use, add an expiration date to the Available through field. 
• If the Quote has not been converted to an Order, remove all instances of the Dealer Option 

used in Quotes to enable the Delete function.  
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HEP Approval Box 

High Exposure Project (i.e., HEP) Approval popup boxes are triggered in CTB Quote™ Plus under certain 
circumstances.  

Scenario:  Quote Items were added to the Shopping Cart and then I received a HEP Approval warning 
box at the top of the Quote. 

 

Resolution:   
• HEP Approval pop-ups prompt for contact with your Outside Sales Representative. 
• An Order can still be placed, but contact may be made from a Milgard Representative.  

Validation Failure 

Validation Failure popups are generally due to a missing required field.  A commonly overlooked 
required field, Construction Type, is in the Quotes> Header tab, but other empty fields may cause it.   
Required fields have a red asterisk* and if left empty will display a red encircled exclamation point.  

Scenario:  I tried to convert a Quote to an Order.  When I clicked on the Place Order button, I received a 
Validation Failure popup.  

 

Resolution:   
• To place an Order, the Construction Type is a required field* and must be completed. It is 

located on the Place Order screen.  Select one of the required options from the drop-down list 
to resolve the error. 

• On the Validation Failure popup, the message identifies the field(s) that invoked the error. Use 
the Glossary for assistance or review the Quote to locate any missing required* fields. 

• Locate any fields with a red asterisk* or a red encircled exclamation point to ensure a response 
or selection has been made.  Select the Place Order button to verify that all required fields* 
have been completed. 

This image cannot currently be displayed.

This image cannot currently be displayed.

This image cannot currently be displayed.
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Preferences Caution Popup 

Preferences have a few rules applied to assist with the pre-build selections.  Product Line is the first rule 
applied and filters the options available for other field selections.  If a Preference selection is made and 
then Product Line is changed, for example, a caution popup appears to advise that a selected option no 
longer applies and needs to be updated. 

Scenario:  I made various Preference selections and then received a popup that reads: “Previous 
selections have been modified. Please verify selections.” 

 
Resolution:   

• Select the Reset selected options button to clear the selected Preferences and start with the 
Product Line selection first.  Then answer fields that are styled bold for the most common build 
selections.   

• Generally, the invalid Preference field is cleared automatically (Exterior Finish in the screenshot 
above)and CTB Quote™ Plus will make it the active field.  Select a valid option for the prompted 
field to resolve.  If you’ve already mouse-clicked away, just review the Preference fields you’d 
like preselected. 

Inactive Project Warning 

Project Status can be set to “Inactive”.  If Quotes have been linked to a Project that is set to “Inactive”, 
CTB Quote™ Plus will provide a popup as a reminder.   

Scenario:  I opened a Quote and received a popup that reads: “Inactive Project Warning.” 

 
Resolution:   

• Remove the link to the Project in the Quote Header tab. 
• Open the Project and change the status to Active.   
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Import-Export 

Exported File Behavior   

Microsoft® Excel Files are not a part of CTB Quote™ Plus, however, the spreadsheet format, for 
exported files, is most often opened with Excel.  Various computer and browser settings can affect file 
viewing behavior. 

Scenario:  I exported a Proofing Report and it isn’t opening in Excel. 

Resolution:   
• Resolving different computer behaviors (between various browsers, Microsoft® Excel, and 

downloaded file security settings) is beyond the scope of this troubleshooting guide.  However, 
it has been noted that confusion may occur when Excel is already open with another file and an 
attempt is made to open an exported file from CTB Quote™ Plus .   

• When the Export button is selected from CTB Quote™ Plus, browsers generally display the file in 
the browser’s footer area and/or auto-save files to the Downloads folder.  Right click on the 
browser-displayed file to save it to a location that is easily found //the Downloads folder is 
generally the primary folder for most Windows users//.  View any open spreadsheets in Excel.  If 
you do not see the file exported from CTB Quote™ Plus, use Excel’s File> Open function to 
browse to the folder where the file was saved.      

Imported XML File is Missing Information 

Scenario:  I received an exported Quote in XML format from a coworker.  After Import, the Customer 
data and pricing Information is missing. 

Resolution:   
• Exported files provide a quick way of sharing Line Items with other users.   By design, CTB 

Quote™ Plus import data only contains configured Line Items (e.g., Window and Door builds).     

My Imported XML File Caused an Invalid Shopping Cart Popup 

Scenario:  I imported a Quote in XML format from a coworker.  There is now an ‘Invalid Lines in 
Shopping Cart’ error. 

Resolution:   
• Exported XML data requires a Customer and Location to verify build requirements, which can 

differ from location to location.  Ensure Customer and Location are completed. 
• Select the Validate All button to run the verification tool.   
• If the Invalid Shopping Cart popup is still visible after running the Validate All tool, line items 

need changes to meet build requirements.  Select the Edit link to update.  The Item 
Configurator will open to any fields that need attention. 
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